Quite Software  

You are here: Quite > Products > Quite Imposing > Download

 
         
   

Quite Imposing 2.0 logo

Download software
Quite Imposing Plus
Current Version 4.0i (10 Oct 2016)

1. Check the system requirements

You will need the following:

  • A computer running a full copy of Adobe Acrobat (Standard or Professional) . The free Adobe Reader or Acrobat Reader will not work.
  • For the Macintosh version, a Macintosh running Mac OS X 10.7 to 10.12 and Acrobat 9.0/10.0/11.0/DC Professional. Earlier versions of Acrobat will not work. Please read Adobe's system requirements carefully. For instance, Acrobat DC requires Mac OS 10.9 or above.
  • For the Windows version, Windows 7 or later and Acrobat 9.0/10.0/11.0/DC (Standard or Professional). The plug-ins are supported on the same Microsoft Windows system as Acrobat. Please read Adobe's system requirements carefully. For instance, Acrobat DC requires Windows 7 or above.

2. Go to the appropriate download page

Now select Windows or Macintosh.

So good that you want to share the plug-in?

We are happy for you to give copies of the plug-in to your friends and colleagues, so that they can try out a demonstration too. You must not pass on any serial number you may have been issued with. If you would like to include the plug-in on a web site or CDROM you must contact us first.