Quite Software  

You are here: Quite > Products > Quite Imposing > Download > Macintosh

 
         
 

Quite Imposing

Download for Macintosh

Other info

 

Quite Imposing 2.0 logo

Download Macintosh software

Quite Imposing Plus for Macintosh

1. Make sure you have what you need

You should be have Mac OS 10.7 to 10.12.

You should be running Acrobat 9.0/10.0/11.0/DC Professional (including Creative Cloud) on a compatible Mac OS system.

2. Download the software

You can download and use Quite Imposing Plus. This is the full software, but unless you previously purchased it, it will work for you in a demonstration mode. The main effect of this is that all your imposed pages will be marked with a large X. You can still print your imposed pages to fully test the software.

  • Quite Imposing Plus for Macintosh - qiplus4_en.dmg. Version 4.0i, uploaded 10 Oct 2016

If you have previously purchased or downloaded any earlier version since 4.0, you can install this new version over the top of the old; licensing information is preserved. If you have a license for version 1, 2 or 3, you may need to purchase an upgrade.

3. Run the installer

In the folder that opens you should see Install Quite Plugins. Simply double click on this to install your plug-ins. The installer will try to locate your copy of Acrobat, but if it fails you can click the Browse button to locate it yourself.

If you don't seem to have an Install Quite Plugins file yet, you should read our instructions on installing software from a DMG file.

If you get a message about "unidentified developer", this is normal Mac behaviour. Right click on Install Quite Plugins, choose Open then click Open in the next message. For details please see this page.

4. Start Acrobat

If all is well, you will now have a new menu item Plug-ins > Quite Imposing Plus 4 > Imposition control panel. Select this and you should see a window About Quite Imposing Plus. Click OK to start working, or click Guide to start reading the online guide.

Removing the plug-in

Re-run the installer, and you can choose to uninstall.

Upgrading between versions of Acrobat

When you install a new version of Acrobat, the location of plug-ins will be different, will need to reinstall the plug-in.